<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
  <head>
    <meta charset="utf-8" />
<script>window.dataLayer = window.dataLayer || []; window.dataLayer.push({"drupalLanguage":"en","drupalCountry":"KE","siteName":"Kenyans.co.ke","entityCreated":"1573135474","entityLangcode":"en","entityStatus":"1","entityUid":"23143","entityUuid":"f1561293-a88a-42a1-a013-5b130b96a9c2","entityVid":"160110","entityName":"harmon","entityType":"node","entityBundle":"news","entityId":"46112","entityTitle":"Gunshots as Mariga is Chased From Kibra Polling Station [VIDEO]","userUid":0});</script>
<meta name="title" content="Gunshots as Mariga is Chased From Kibra Polling Station [VIDEO] - Kenyans.co.ke" />
<link rel="canonical" href="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video" />
<meta property="og:site_name" content="Kenyans.co.ke" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="fb:pages" content="https://www.facebook.com/Kenyans.co.ke" />
<meta http-equiv="content-language" content="EN" />
<meta property="fb:admins" content="639485812,100001003454999" />
<meta property="og:type" content="Article" />
<meta name="twitter:site" content="@Kenyans" />
<meta name="twitter:description" content="Gunshots momentarily rented the air in Kibra moments after Jubilee Candidate McDonald Mariga drove into a crowded..." />
<meta name="description" content="Gunshots momentarily rented the air in Kibra moments after Jubilee Candidate McDonald Mariga drove into a crowded..." />
<meta property="fb:app_id" content="457717871056325" />
<meta property="og:url" content="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video" />
<meta name="abstract" content="Gunshots momentarily rented the air in Kibra moments after Jubilee Candidate McDonald Mariga drove into a crowded..." />
<meta name="twitter:site:id" content="38737371" />
<meta name="twitter:creator:id" content="38737371" />
<meta property="og:title" content="Gunshots, Chaos as Mariga is Chased From Kibra [VIDEO]" />
<meta name="twitter:creator" content="@Kenyans" />
<meta name="twitter:url" content="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video" />
<meta property="og:description" content="Gunshots momentarily rented the air in Kibra moments after Jubilee Candidate McDonald Mariga drove into a crowded..." />
<meta name="twitter:image" content="https://www.kenyans.co.ke/files/styles/article_style/public/images/news/mariga-kibra_0.jpg?itok=6Bhpqe9D" />
<meta property="og:image" content="https://www.kenyans.co.ke/files/styles/article_style/public/images/news/mariga-kibra_0.jpg?itok=6Bhpqe9D" />
<meta property="article:publisher" content="https://www.facebook.com/Kenyans.co.ke" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "NewsArticle",
            "name": "Gunshots as Mariga is Chased From Kibra Polling Station [VIDEO]",
            "headline": "Gunshots as Mariga is Chased From Kibra Polling Station [VIDEO]",
            "description": "Gunshots momentarily rented the air in Kibra moments after Jubilee Candidate McDonald Mariga drove into a crowded...",
            "image": {
                "@type": "ImageObject",
                "representativeOfPage": "True",
                "url": "https://www.kenyans.co.ke/files/styles/article_style/public/images/news/mariga-kibra_0.jpg?itok=6Bhpqe9D"
            },
            "datePublished": "2019-11-07T17:14:13+0300",
            "dateModified": "2019-11-07T17:33:52+0300",
            "author": {
                "@type": "Person",
                "name": "harmon"
            },
            "publisher": {
                "@type": "Organization",
                "name": "Kenyans.co.ke",
                "url": "https://www.kenyans.co.ke",
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://www.kenyans.co.ke/themes/kenyans/css/images/kenyans_logo_new.png"
                }
            },
            "mainEntityOfPage": "https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video"
        }
    ]
}</script>
<link rel="amphtml" href="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video?amp=1" />
<link rel="shortcut icon" href="/files/kenyans-newfavicon.png" type="image/png" />
<script>window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};</script>

    <title>Gunshots as Mariga is Chased From Kibra Polling Station [VIDEO] - Kenyans.co.ke</title>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5Q4RHCB');</script>
<!-- End Google Tag Manager -->
    <link rel="stylesheet" media="all" href="/files/css/css_Ceps1eRor4rMxP91yWO_eTh49ybxbY4xYdDNclrISKY.css?pzr3fw" />
<link rel="stylesheet" media="all" href="/files/css/css_yH_vEupTsE91JAGtTpUrZo6jyzMYXYVMCX7lbZkDm-M.css?pzr3fw" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Exo+2:400,700" />

    
<!--[if lte IE 8]>
<script src="/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->
<script src="https://use.fontawesome.com/releases/v5.1.1/js/all.js" defer></script>
<script src="https://use.fontawesome.com/releases/v5.1.1/js/v4-shims.js" defer></script>

    <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
  <!--[if lt IE 9]>
    <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->
  <!--[if gte IE 9]>
  <style type="text/css">
    .gradient {
       filter: none;
    }
  </style>
<![endif]-->
<!-- google page-level ads -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5144984056763328",
    enable_page_level_ads: true
  });
</script>
<!-- end google page-level ads -->
<meta property="fb:app_id" content="457717871056325" />
<meta property="fb:admins" content="639485812"/>
<meta property="fb:admins" content="100001003454999"/>

  </head>
  <body class="not-front page-news">
    <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5Q4RHCB"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div class="bg-image-old bg-skin">
<!-- /72379320/KE-Background_Skin -->
<div id='div-gpt-ad-1462889861242-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462889861242-0'); });
</script>
</div>
</div><!-- .bg-image -->
<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId            : '457717871056325',
      autoLogAppEvents : true,
      xfbml            : true,
      version          : 'v4.0'
    });
  };
</script>
<script async defer src="https://connect.facebook.net/en_US/sdk.js"></script>
  <div class="scanlines"></div>
  <div class="full-width">
    <a href="#main-content" class="visually-hidden focusable">
      Skip to main content
    </a>
    
      <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    <div class="layout-container full-width">
  <div id="bodyWrapper">
  <div class="header clearfix">
  <header role="banner">
    <div class="headerLeft">
        <div>
    <div id="block-sitebranding">
  
    
        <a href="/" title="Home" rel="home">
      <img src="/files/kenyans-newlogo-2019-250x90-2.png" alt="Home" />
    </a>
      
</div>

  </div>

    </div>
  </header>

  <div class="mobile-menu">
    <div class="menu-icon"><a href="#"><i class="fa fa-list"></i></a>
    </div>
    <div class="menu-text"><a href="#">Menu</a>
    </div>
  </div>

    <div class="headerRight">
      <div>
    <div id="block-ketopleaderboard" class="block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-leaderboard ad-top-leaderboard"><!-- /72379320/KE-TopLeaderboard -->
<div id="div-gpt-ad-1462461665695-0"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-0'); });
</script></div>
</div>
<!-- .ad-kenyans --></div>
<!-- .ad-kenyans-wrapper --></div>
      
  </div>

  </div>

   </div>
   
  </div> <!-- end header clearfix -->

<div id="navigation" class="clearfix">
  <nav id="access" role="navigation">
    <div class="nav">
        <div>
    <nav role="navigation" aria-labelledby="block-mainmenu-2-menu" id="block-mainmenu-2" class="mainmenu">
            
  <h2 class="visually-hidden" id="block-mainmenu-2-menu">Main menu</h2>
  

        
              <ul>
              <li>
        <a href="/" title="" data-drupal-link-system-path="&lt;front&gt;">Home</a>
              </li>
          <li>
        <a href="/news" data-drupal-link-system-path="news">News</a>
              </li>
          <li>
        <a href="/facts" data-drupal-link-system-path="facts">Facts</a>
              </li>
          <li>
        <a href="/artist" data-drupal-link-system-path="artist">Artists</a>
              </li>
          <li>
        <a href="/videos" data-drupal-link-system-path="videos">Videos</a>
              </li>
          <li>
        <a href="/cabinet" data-drupal-link-system-path="cabinet">Govt</a>
              </li>
          <li>
        <a href="/politicians" data-drupal-link-system-path="politicians">Politicians</a>
              </li>
          <li>
        <a href="/counties" data-drupal-link-system-path="counties">Counties</a>
              </li>
          <li>
        <a href="/contact" data-drupal-link-system-path="node/77">Contact</a>
              </li>
        </ul>
  


  </nav>

  </div>

    </div>
  </nav>
</div>




<div class="pageWrapper clearfix">
    
      <div class="highlightedWrapper clearfix">
        <div>
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>

    </div>
  
      <div id="contentTop">
        <div>
    <div id="block-kemenuleaderboardlarge" class="block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-desktop ad-leaderboard-large">
<!-- /72379320/KE-MenuLeaderboard-Large -->
<div id='div-gpt-ad-1462461665695-3' style='height:90px; width:970px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-3'); });
</script>
</div>
</div> <!-- ad-kenyans -->
</div> <!-- .ad-kenyans-wrapper --></div>
      
  </div>
<div id="block-kemobile300x2501inner" class="block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-mobile ad-mobile-top300x250">
<!-- /72379320/KE-Mobile-300x250-1-Inner -->
<div id='div-gpt-ad-1506658102850-0' style='max-width:320px; margin: 0 auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1506658102850-0'); });
</script>
</div>
</div> <!-- .ad-kenyans -->
</div> <!-- .ad-kenyans-wrapper --></div>
      
  </div>
<div class="views-element-container" id="block-views-block-breaking-news-block-1">
  
    
      <div><div class="js-view-dom-id-3741733b0c8916e701a7049b81e0f5cde150c824572b37235676956bcf09ad7b">
  
  
  

  
  
  

      <div class="views-row"><div><div class="breaking"><a href="/news/46082-kibra-showdown-live-blog-break-down-highly-contested-polls"><span class="breaking-header">Live Blog</span>Jubilee - ODM Kibra Showdown &raquo;</a></div></div></div>

    

  
  

  
  
</div>
</div>

  </div>

  </div>

    </div>
  
  
  <div class="outerWrapper clearfix">
    <div class="innerWrapper   right-present">









  <main role="main">
    <a id="main-content" tabindex="-1"></a>      
      <div class="contentWrapper clearfix layout-content">
          <div>
    <div id="block-kenyans-page-title">
  
    
      
  <h1>Gunshots as Mariga is Chased From Kibra Polling Station [VIDEO]</h1>


  </div>
<div id="block-kenyans-system-main">
  
    
        <div class="layout layout--onecol">
    <div  class="layout__region layout__region--content">
      <div class="block-region-content"><div class="views-element-container">
  
    
      <div><div class="js-view-dom-id-da2854fd281f8b23c6542319f6f734fe9b5725c19f6b2d1cdee7e0c3ff3fbe7d">
  
  
  

  
  
  

  <div class="item-list news-article">
  
  <ul>

          <li><div class="byline">By <span class="news-author"><a href="/by/harmon">Harmon Ellen</a></span> on <span class="news-published"><em>7 November 2019 - 5:14 pm
</em></span></div><div class="news-image">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/files/styles/article_style/public/images/news/mariga-kibra_0.jpg?itok=6Bhpqe9D 1x" media="all and (min-width: 971px)" type="image/jpeg"/>
              <source srcset="/files/styles/article_style/public/images/news/mariga-kibra_0.jpg?itok=6Bhpqe9D 1x" media="all and (min-width: 481px) and (max-width: 970px)" type="image/jpeg"/>
              <source srcset="/files/styles/article_style_mobile/public/images/news/mariga-kibra_0.jpg?itok=HrP25LIF 1x" media="(min-width: 0)" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            <img src="/files/styles/article_style_mobile/public/images/news/mariga-kibra_0.jpg?itok=HrP25LIF" alt="" typeof="foaf:Image" />

  </picture>

</div><div class="news-image"><div class="image-caption">Jubilee candidate McDonald Mariga addressing the press on Thursday, November 7 <span class="image-credit">File </span></div></div></li>
    
  </ul>

</div>

    

  
  

  
  
</div>
</div>

  </div>
<div class="block">
  
    
      
            <div><div class="article-ad article-ad-1">
<!-- /72379320/KE-300x250-Articles -->
<div id='div-gpt-ad-1462461665695-4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-4'); });
</script>
</div>
</div></div>
      
  </div>
<div>
  
    
      <span class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video" data-a2a-title="Gunshots as Mariga is Chased From Kibra Polling Station [VIDEO]"><a class="a2a_button_facebook"></a><a class="a2a_button_twitter"></a><a class="a2a_button_whatsapp"></a><a class="a2a_button_facebook_messenger"></a><a class="a2a_button_email"></a></span>
  </div>
<div class="views-element-container">
  
    
      <div><div class="js-view-dom-id-24f8df3adf6061136b4c42e557bdc5a0d48388af6942239074225f763992de93">
  
  
  

  
  
  

  <div class="item-list news-article">
  
  <ul>

          <li><p>The situation at Kibra constituency turned chaotic on Thursday, November 7, after Jubilee candidate <strong>McDonald Mariga</strong> was chased away minutes after he arrived at a polling station.</p>
<p>In a video that has since gone viral, the Jubilee Party Kibra candidate arrived at Ayany Primary School Polling Station reportedly in the company of police, however, residents at the polling station shooed him away.</p>
<p>The situation took a rather ugly turn as police were forced to shoot in the air to disperse the rowdy crowd.</p>
<p><figure role="group"><div alt="A screenshot of McDonald Mariga's Hummer shortly after arriving at a Kibra polling station on Thursday, November 7, 2019." data-embed-button="file_browser" data-entity-embed-display="image:image" data-entity-embed-display-settings="article_inner file" data-entity-type="file" data-entity-uuid="1a31865e-3c0c-467d-a179-7919a4ab23e2" data-langcode="en" class="embedded-entity">  <a href="https://www.kenyans.co.ke/files/images/news/hummer.jpg"><img src="/files/styles/article_inner/public/images/news/hummer.jpg?itok=15e2_cMW" width="700" height="358" alt="A screenshot of McDonald Mariga's Hummer shortly after arriving at a Kibra polling station on Thursday, November 7, 2019." typeof="foaf:Image" /></a>
</div>
<figcaption>A screenshot of McDonald Mariga's Hummer shortly after arriving at a Kibra polling station on Thursday, November 7, 2019.</figcaption></figure></p><p><em>"Kwenda! Kwenda Kabisa, wewe si utoe gari uende </em>(Go away, take your car and leave) a resident is heard ordering.</p>
<p><a href="https://www.kenyans.co.ke/news/46100-marigas-hummer-turning-heads-kibra-video" rel="nofollow">Mariga's luxury SUV</a> (Hummer) is seen being swiftly driven off closely followed by the rest of his entourage.</p>
<p>Earlier on, Mariga had visited Lindi Mosque Polling Station and had received a warm welcome.</p>
<p>ODM's <strong>Philip Etale</strong> who also shared the misfortune on his Facebook mocking Mariga by referring to him as a goon.</p>
<p>"Mariga goes to Ayany Primary School polling station in the company of police officers in Subaru SSD 131F white in colour and GD12MDX Subaru green in colour. Immediately he enters, the officers start shooting in the air. Mariga is a goon," he posted.</p>
<p>In another video that went viral Mariga could be arriving at a polling station in his expensive H2 Hummer amidst jubilation of the residents.</p>
<p>Some could be heard challenging him to alight from the high-end car and finish the rest of his journey on foot like the fit former soccer star he is to which he obliged.</p>
<p>On alighting, he freely interacted with the crowd next to Kibera Secondary School's signpost.</p>
<div class="video-embed-field-provider-facebook video-embed-field-responsive-video"><iframe width="854" height="480" frameborder="0" allowfullscreen="allowfullscreen" src="https://www.facebook.com/video/embed?video_id=508650266650334"></iframe>
</div>
</li>
    
  </ul>

</div>

    

  
  

  
  
</div>
</div>

  </div>
<div class="views-element-container">
  
    
      <div><div class="js-view-dom-id-ca322ec1f296abe59f0be97ee434bcf6ffddb0f938b653e7e3215686df081e82">
  
  
  

  
  
  

  <div class="item-list social-wrapper">
  
  <ul>

          <li><div class="facebook-comments"><div class="fb-comments" data-href="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video " data-numposts="20" by="reverse_time" data-order-by="reverse_time" data-colorscheme="light" data-width="100%" width="100%"></div></div></li>
    
  </ul>

</div>

    

  
  

  
  
</div>
</div>

  </div>
<div class="block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-mobile ad-mobile-bottom300x250">
<!-- /72379320/KE-320x100-2 -->
<div id='div-gpt-ad-1507664486956-1'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1507664486956-1'); });
</script>
</div>
</div> <!-- ad-kenyans -->
</div> <!-- ad-kenyans-wrapper --></div>
      
  </div>
<div class="block">
  
    
      
            <div><!-- <div class="g-matched">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> -->
<!-- BelowArticle -->
<!-- <ins class="adsbygoogle"
     style="display:block; width: 740px; height: 220px;"
     data-ad-client="ca-pub-5144984056763328"
     data-ad-slot="3545955093"
     data-ad-format="autorelaxed"> </ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div> --> <!-- g-matched -->

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:inline-block;width:740px;height:220px"
     data-ad-client="ca-pub-5144984056763328"
     data-ad-slot="7664809241"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
      
  </div>
<div class="views-element-container">
  
    
      <div><div class="js-view-dom-id-26388297212038b5fbb062b41c5c32f87bedb9b6b072ef78929073f3a34e8f53">
  
  
  

      <header>
      
    </header>
  
  
  

  <div class="item-list news-list news-list-wrapper news-list-secondary">
  
  <ul>

          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46117-kalonzo-hangs-raila-out-dry">  <img src="/files/styles/article_300x150/public/images/news/pix2_2.jpg?itok=xmfg3SlL" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">Not me</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46117-kalonzo-hangs-raila-out-dry">Kalonzo Hangs Raila Out to Dry</a></div></div><div><div class="news-date">7 November 2019 - 7:00 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46115-jubilee-mp-ambushed-clobbered-kibra-video">  <img src="/files/styles/article_300x150/public/images/news/untitled_design_-_2019-11-07t175808.163.jpg?itok=f7hYV4_j" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">chaotic</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46115-jubilee-mp-ambushed-clobbered-kibra-video">Jubilee MP Ambushed &amp; Clobbered in Kibra [VIDEO]</a></div></div><div><div class="news-date">7 November 2019 - 6:33 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46114-nmg-editor-loses-property-brazen-night-raid">  <img src="/files/styles/article_300x150/public/images/news/nmgpic_5.jpg?itok=9JPYxZp1" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">by a whisker</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46114-nmg-editor-loses-property-brazen-night-raid">NMG Editor Robbed at Gunpoint </a></div></div><div><div class="news-date">7 November 2019 - 5:54 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46113-kenyans-who-will-pay-govt-using-internet">  <img src="/files/styles/article_300x150/public/images/news/eiw7piqxyaia7jz.jpg?itok=IIwX7D2y" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">details</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46113-kenyans-who-will-pay-govt-using-internet">Kenyans Who Will Pay Govt for Using The Internet</a></div></div><div><div class="news-date">7 November 2019 - 5:40 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video">  <img src="/files/styles/article_300x150/public/images/news/mariga-kibra_0.jpg?itok=ZKK1A61q" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">UGLY</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46112-gunshots-mariga-chased-kibra-video">Gunshots, Chaos as Mariga is Chased From Kibra [VIDEO]</a></div></div><div><div class="news-date">7 November 2019 - 5:14 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46111-citizen-tvs-jeff-koinange-partys-new-york-kenyas-elite-video">  <img src="/files/styles/article_300x150/public/images/news/eiw8pqoxkaeiigf.jpg?itok=4C9Zdg7K" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">Big Leagues</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46111-citizen-tvs-jeff-koinange-partys-new-york-kenyas-elite-video">Jeff Koinange Parties in New York With Kenya&#039;s Elite [VIDEO]</a></div></div><div><div class="news-date">7 November 2019 - 5:33 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46110-brave-woman-exposes-rot-sonkos-backyard-video">  <img src="/files/styles/article_300x150/public/images/news/nairobi_county_governor_mike_sonko_5.jpg?itok=wnSCTLHh" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">shocking</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46110-brave-woman-exposes-rot-sonkos-backyard-video">Brave Woman Exposes Rot in Sonko&#039;s Backyard [VIDEO]</a></div></div><div><div class="news-date">7 November 2019 - 4:16 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46108-churchill-show-comedian-found-dead">  <img src="/files/styles/article_300x150/public/images/news/churchill_showa_0.jpg?itok=ZVRPuBS0" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">Sad</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46108-churchill-show-comedian-found-dead">Churchill Show Comedian Found Dead</a></div></div><div><div class="news-date">7 November 2019 - 3:46 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46107-uhuru-forced-backdown-fight-maraga">  <img src="/files/styles/article_300x150/public/images/news/uninrofut90g4g2eh5b9d7b402b7cf.jpg?itok=xwSv0xK6" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">concedes</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46107-uhuru-forced-backdown-fight-maraga">Uhuru Forced to Back Down in Fight With Maraga</a></div></div><div><div class="news-date">7 November 2019 - 3:39 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46106-leaked-audio-exposes-how-legislators-conspire-eat-public-funds">  <img src="/files/styles/article_300x150/public/images/news/kiambu-pic_4.jpg?itok=ZN7s6H7h" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">Red-Handed</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46106-leaked-audio-exposes-how-legislators-conspire-eat-public-funds">Leaked Audio Exposes How Legislators Conspire to Loot Public Funds</a></div></div><div><div class="news-date">7 November 2019 - 5:06 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46104-photos-prove-uhurus-sons-clothing-line-redefining-fashion">  <img src="/files/styles/article_300x150/public/images/news/uhurus-family_1.jpg?itok=1hHvutvl" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">Taking Over</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46104-photos-prove-uhurus-sons-clothing-line-redefining-fashion">Photos That Prove Uhuru&#039;s Son Redefines Fashion</a></div></div><div><div class="news-date">7 November 2019 - 2:56 pm</div></div></li>
          <li class="news-list-row other-news clearfix"><div><div class="news-image"><a href="https://www.kenyans.co.ke/news/46105-waiguru-discloses-kenyan-politician-she-fears-most-video">  <img src="/files/styles/article_300x150/public/images/news/ann-waiguru_9.jpg?itok=sJbtaPza" width="300" height="150" alt="" typeof="Image" />


<div class="news-secondary">mentor</div></a></div></div><div><div class="news-title-list"><a href="https://www.kenyans.co.ke/news/46105-waiguru-discloses-kenyan-politician-she-fears-most-video">Powerful Kenyan Politician Behind Waiguru&#039;s Success [VIDEO]</a></div></div><div><div class="news-date">7 November 2019 - 3:34 pm</div></div></li>
    
  </ul>

</div>

    

  
  

      <footer>
      <div class="read-more"><a href="/news/">More News</a></div>
    </footer>
  
  
</div>
</div>

  </div>
</div>
    </div>
  </div>

  </div>
<div id="block-kenyans-block-14" class="block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-leaderboard ad-top-leaderboard"><!-- /72379320/KE-TopLeaderboard -->
<div id="div-gpt-ad-1462461665695-0"><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-0'); });
</script></div>
</div>
<!-- .ad-kenyans --></div>
<!-- .ad-kenyans-wrapper --></div>
      
  </div>
<div id="block-kenyans-block-18" class="block-ad block-ad-article-1 block">
  
    
      
            <div><div class="article-ad article-ad-1">
<!-- /72379320/KE-300x250-Articles -->
<div id='div-gpt-ad-1462461665695-4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-4'); });
</script>
</div>
</div></div>
      
  </div>
<div id="block-kenyans-block-39" class="block-ad block-ad-article-2 block">
  
    
      
            <div><div class="article-ad article-ad-2">
<!-- /72379320/KE-300x250-Articles-2 -->
<div id='div-gpt-ad-1506580564732-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1506580564732-0'); });
</script>
</div>
</div></div>
      
  </div>
<div id="block-kenyans-block-44" class="block-ad block-ad-article-2in block">
  
    
      
            <div><div class="article-ad article-ad-2in">
<!-- /72379320/KE-300x250-Articles-2-Inner -->
<div id='div-gpt-ad-1507750963468-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1507750963468-0'); });
</script>
</div>
</div></div>
      
  </div>
<div id="block-kenyans-block-45" class="block-ad block-ad-article-3 block">
  
    
      
            <div><div class="article-ad article-ad-3">
<!-- /72379320/KE-300x250-Articles-3 -->
<div id='div-gpt-ad-1507752217570-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1507752217570-0'); });
</script>
</div>
</div></div>
      
  </div>
<div id="block-kemobile300x2503" class="block-ad block-ad-mobile3 block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-mobile ad-mobile-bottom300x250">
<!-- /72379320/KE-Mobile-300x250-3 -->
<div id='div-gpt-ad-1462461665695-7'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-7'); });
</script>
</div>
</div> <!-- ad-kenyans -->
</div> <!-- ad-kenyans-wrapper --></div>
      
  </div>

  </div>

      </div>    </div> <!-- end .innerWrapper -->
  </div> <!-- end .outerWrapper -->

    
          <aside class="sidebarRight clearfix layout-sidebar-second" role="complementary">
          <div>
    <div class="views-exposed-form clearboth" data-drupal-selector="views-exposed-form-search-page-1" id="block-exposedformsearchpage-1-2">
  
    
      <form action="/search" method="get" id="views-exposed-form-search-page-1" accept-charset="UTF-8">
  <div class="js-form-item form-item js-form-type-select form-item-query js-form-item-query">
      <label for="edit-query">Operator</label>
        <select data-drupal-selector="edit-query" id="edit-query" name="query" class="form-select"><option value="and" selected="selected">Contains all of these words</option><option value="or">Contains any of these words</option><option value="not">Contains none of these words</option></select>
        </div>
<div class="js-form-item form-item js-form-type-textfield form-item-search js-form-item-search form-no-label">
        <input placeholder="Search Kenyans.co.ke" data-drupal-selector="edit-search" type="text" id="edit-search" name="search" value="" size="30" maxlength="128" class="form-text" />

        </div>
<div class="js-form-item form-item js-form-type-select form-item-sort-by js-form-item-sort-by">
      <label for="edit-sort-by">Sort by</label>
        <select data-drupal-selector="edit-sort-by" id="edit-sort-by" name="sort_by" class="form-select"><option value="created_1" selected="selected">Date</option><option value="search_api_relevance">Relevance</option></select>
        </div>
<div class="js-form-item form-item js-form-type-select form-item-sort-order js-form-item-sort-order">
      <label for="edit-sort-order">Order</label>
        <select data-drupal-selector="edit-sort-order" id="edit-sort-order" name="sort_order" class="form-select"><option value="ASC">ASC.</option><option value="DESC" selected="selected">DESC.</option></select>
        </div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions"><input data-drupal-selector="edit-submit-search" type="submit" id="edit-submit-search" value="Search" class="button js-form-submit form-submit" />
</div>


</form>

  </div>
<div id="block-kenyans-block-22" class="blockpad block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-medium-rect ad-medium-rect-1">
<!-- /72379320/KE-MediumRect1 -->
<div id='div-gpt-ad-1462461665695-8'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-8'); });
</script>
</div>
</div> <!-- .ad-kenyans -->
</div> <!-- .ad-kenyans-wrapper --></div>
      
  </div>
<div class="views-element-container" id="block-views-block-news-block-7">
  
    
      <div><div class="popular js-view-dom-id-4bac1a5f4b3fa565f052fba99c123fc958f90bd1a3de73c2ee0e98097a8ed6a4">
  
  
  

      <header>
      <h2 class="block-header"><a href="/news">Latest News</a></h2>
    </header>
  
  
  

  <div class="item-list news-list news-list-wrapper front-news-list headlines">
  
  <ul>

          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46117-kalonzo-hangs-raila-out-dry"><span class="counter">1</span> Kalonzo Hangs Raila Out to Dry</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46115-jubilee-mp-ambushed-clobbered-kibra-video"><span class="counter">2</span> Jubilee MP Ambushed &amp; Clobbered in Kibra [VIDEO]</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46114-nmg-editor-loses-property-brazen-night-raid"><span class="counter">3</span> NMG Editor Robbed at Gunpoint </a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46113-kenyans-who-will-pay-govt-using-internet"><span class="counter">4</span> Kenyans Who Will Pay Govt for Using The Internet</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46112-gunshots-mariga-chased-kibra-video"><span class="counter">5</span> Gunshots, Chaos as Mariga is Chased From Kibra [VIDEO]</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46111-citizen-tvs-jeff-koinange-partys-new-york-kenyas-elite-video"><span class="counter">6</span> Jeff Koinange Parties in New York With Kenya&#039;s Elite [VIDEO]</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46110-brave-woman-exposes-rot-sonkos-backyard-video"><span class="counter">7</span> Brave Woman Exposes Rot in Sonko&#039;s Backyard [VIDEO]</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46108-churchill-show-comedian-found-dead"><span class="counter">8</span> Churchill Show Comedian Found Dead</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46107-uhuru-forced-backdown-fight-maraga"><span class="counter">9</span> Uhuru Forced to Back Down in Fight With Maraga</a></div></li>
          <li class="news-list-row clearfix"><div class="news-title-list"><a href="/news/46106-leaked-audio-exposes-how-legislators-conspire-eat-public-funds"><span class="counter">10</span> Leaked Audio Exposes How Legislators Conspire to Loot Public Funds</a></div></li>
    
  </ul>

</div>

    

  
  

  
  
</div>
</div>

  </div>
<div id="block-kenyans-block-23" class="block">
  
    
      
            <div><!-- /72379320/KE-MediumRect2 -->
<div id='div-gpt-ad-1462461665695-9' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-9'); });
</script>
</div></div>
      
  </div>
<div id="block-kenyans-block-6" class="block">
  
    
      
            <div><div class="social-twitter"><a href="https://twitter.com/Kenyans" class="twitter-follow-button" data-show-count="false" data-size="large">Follow @Kenyans</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div class="fb-wrapper"><div class="fb-page" data-href="https://www.facebook.com/Kenyans.co.ke" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/Kenyans.co.ke"><a href="https://www.facebook.com/Kenyans.co.ke">Kenyans.co.ke</a></blockquote></div></div></div></div>
      
  </div>
<div id="block-kenyans-block-24" class="block">
  
    
      
            <div><!-- /72379320/KE-MediumRect3 -->
<div id='div-gpt-ad-1462461665695-10' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462461665695-10'); });
</script>
</div></div>
      
  </div>
<div id="block-kenyans-block-41" class="block">
  
    
      
            <div><div class="ad-kenyans-wrapper">
<div class="ad-kenyans ad-mobile ad-mobile-bottom300x250">
<!-- /72379320/KE-320x100-1 -->
<div id='div-gpt-ad-1507664486956-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1507664486956-0'); });
</script>
</div>
</div> <!-- ad-kenyans -->
</div> <!-- ad-kenyans-wrapper --></div>
      
  </div>

  </div>

      </aside>
    
  </main>


  
  
      <footer role="contentinfo" class="footerWrapper clearfix">
      
    </footer>
  </div> <!-- end #bodyWrapper -->
</div>
  </div>

    
  </div>
<div class="site-info">
  Kenyans.co.ke &nbsp; &copy; &nbsp; <?php echo date("Y"); ?> &nbsp; All Rights Reserved
</div>

    <script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/46112","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ajaxPageState":{"libraries":"addtoany\/addtoany,chosen\/drupal.chosen,chosen_lib\/chosen.css,core\/html5shiv,core\/picturefill,datalayer\/behaviors,extlink\/drupal.extlink,filter\/caption,fontawesome\/fontawesome.svg.shim,kenyans\/fonts,kenyans\/global-styling,kenyans\/kenyans-style,layout_discovery\/onecol,system\/base,video_embed_field\/responsive-video,views\/views.ajax,views\/views.module","theme":"kenyans","theme_token":null},"ajaxTrustedUrl":{"\/search":true},"dataLayer":{"defaultLang":"en","languages":{"en":{"id":"en","name":"English","direction":"ltr","weight":0}}},"data":{"extlink":{"extTarget":true,"extTargetNoOverride":false,"extNofollow":true,"extFollowNoOverride":false,"extClass":"ext","extLabel":"(link is external)","extImgClass":false,"extSubdomains":true,"extExclude":"","extInclude":"","extCssExclude":"","extCssExplicit":"","extAlert":false,"extAlertText":"This link will take you to an external web site. We are not responsible for their content.","mailtoClass":"mailto","mailtoLabel":"(link sends email)"}},"chosen":{"selector":"select:visible","minimum_single":4,"minimum_multiple":4,"minimum_width":0,"use_relative_width":false,"options":{"disable_search":false,"disable_search_threshold":4,"allow_single_deselect":false,"search_contains":false,"placeholder_text_multiple":"Choose some options","placeholder_text_single":"Choose an option","no_results_text":"No results match","max_shown_results":null,"inherit_select_classes":true}},"views":{"ajax_path":"\/views\/ajax","ajaxViews":{"views_dom_id:26388297212038b5fbb062b41c5c32f87bedb9b6b072ef78929073f3a34e8f53":{"view_name":"news2","view_display_id":"block_1","view_args":"","view_path":"\/news\/46112-gunshots-mariga-chased-kibra-video","view_base_path":"feeds\/news\/old","view_dom_id":"26388297212038b5fbb062b41c5c32f87bedb9b6b072ef78929073f3a34e8f53","pager_element":0}}},"user":{"uid":0,"permissionsHash":"e0e22d9c8e0571353ca683be07eafd164ea537f7f3f561bdab5b81a2c3944b32"}}</script>
<script src="/files/js/js_YxMoVc1xNS0QRdxtNgoPQ9SLc_wxOK2qjvtltl3e_hw.js"></script>
<script src="https://static.addtoany.com/menu/page.js" async></script>
<script src="/files/js/js_hr_d6QoDNBHFRDQZwCaVo7RbRtnmf2CARE1w64tlFnE.js"></script>

<!-- Start -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"ar0Jl1aE+GW1uG", domain:"kenyans.co.ke",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=ar0Jl1aE+GW1uG" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End -->  
<!-- /72379320/Float100x100 -->
<div id='div-gpt-ad-1484401609901-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1484401609901-0'); });
</script>
</div>

<!-- /72379320/Interstitial_Floater -->
<div id='div-gpt-ad-1492131425263-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1492131425263-0'); });
</script>
</div>

<!-- start mobile interstitial -->
<!-- /72379320/Interstitial-Mobile -->
<div id='div-gpt-ad-1498675843274-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1498675843274-0'); });
</script>
</div>
<!-- end mobile interstitial -->

<!-- /72379320/Slider-Desktop -->
<div id='div-gpt-ad-1525471213381-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1525471213381-0'); });
</script>
</div>

<!-- /72379320/Slider-Mobile -->
<div id='div-gpt-ad-1525471213381-1'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1525471213381-1'); });
</script>
</div>
<!-- end slider mobile -->
  </body>
</html>
